Re: jbd : config_jbd_debug cannot create /proc entry

From: Jose R. Santos
Date: Thu Sep 27 2007 - 01:23:23 EST


On Wed, 26 Sep 2007 14:35:39 -0700
Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> wrote:

> On Tue, 25 Sep 2007 16:36:08 +0200
> Jan Kara <jack@xxxxxxx> wrote:
>
> > > On Tue, 25 Sep 2007 07:49:38 -0500
> > > "Jose R. Santos" <jrs@xxxxxxxxxx> wrote:
> > >
> > > > On Tue, 25 Sep 2007 13:50:46 +0200
> > > > Jan Kara <jack@xxxxxx> wrote:
> > > > > > Jan Kara wrote:
> > > > > > >>
> > > > > > >-#define create_jbd_proc_entry() do {} while (0)
> > > > > > >-#define remove_jbd_proc_entry() do {} while (0)
> > > > > > >+static ctl_table fs_table[] = {
> > > > > > >+ {
> > > > > > >+ .ctl_name = -1, /* Don't want it */
> > > > > >
> > > > > >
> > > > > >
> > > > > > shouldn't this be CTL_UNNUMBERED ?
> > > > > Oh, it should be. I didn't notice we have this :) Thanks for notifying
> > > > > me. Attached is a fixed version.
> > > >
> > > > This was fixed in JBD2 by moving the jbd-debug file to debugfs:
> > > > http://lkml.org/lkml/2007/7/11/334
> > > >
> > > > Since this code is already in the kernel, we should keep it consistent.
> > > >
> > >
> > > OK. Here's a quick patch to fix this. Adapted from the JBD2 patch.
> > > Let me know what you think.
> > Looks fine - exactly what I've just done here :).
>
> hm. I found rather a lot of issues. If this patch is derived from the
> JBD2 patch then perhaps the JBD2 patch needs some looking at.

Some of the changes do apply to the JBD2 patch. I'll send a cleanup patch.

>
> > > Signed-off-by: Jose R. Santos <jrs@xxxxxxxxxx>
> > You can add Signed-off-by: Jan Kara <jack@xxxxxxx>
>
> I suspect you might be getting your signed-off-bys and acked-bys mixed up.
> (If not this patch, then the previous one). Please see
> Documentation/SubmittingPatches section 13 for the difference.
>
> Jose, please review and if possible runtime test these proposed changes?

Agree with all the changes and they worked as expected on my system.

> From: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>
>
> - use `#ifdef foo' instead of `#if defined(foo)'
>
> - CONFIG_JBD_DEBUG depends on CONFIG_DEBUG_FS so we don't need to duplicate
> that logic in the .c file ifdefs
>
> - Make journal_enable_debug __read_mostly just for the heck of it
>
> - Make jbd_debugfs_dir and jbd_debug static
>
> - debugfs_remove(NULL) is legal: remove unneeded tests
>
> - jbd_create_debugfs_entry is a better name than create_jbd_debugfs_entry
>
> - ditto remove_jbd_debugfs_entry
>
> - C functions are preferred over macros
>
> Cc: "Jose R. Santos" <jrs@xxxxxxxxxx>
> Cc: <linux-ext4@xxxxxxxxxxxxxxx>
> Cc: Jan Kara <jack@xxxxxxx>
> Cc: Jose R. Santos <jrs@xxxxxxxxxx>
> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>

Acked-by: Jose R. Santos <jrs@xxxxxxxxxx>

-JRS
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/