Re: [RFC] New kernel-message logging API
Date: Tue Sep 25 2007 - 03:51:06 EST
>> Even the "kp_" prefix is actually pretty unnecessary. It's "info"
>> and a human-readable string that make it recognizable as a log message.
> While I agree a prefix isn't necessary, info, warn, err
> are already frequently #define'd and used.
> kp_<level> isn't currently in use.
> $ egrep -r -l --include=*.[ch] "^[[:space:]]*#[[:space:]]*define[[:space:]]+(info|err|warn)\b" * | wc -l
Sorry for being unclear. I wasn't seriously recommending no prefix,
due to name collisions (exactly your point), but rather saying that no
prefix is necessary for human understanding.
Something to avoid the ambiguity is still useful. I was just saying
that it can be pretty much anything withouyt confusing the casual
We're in violent agreement, I just didn't say it very well the first
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/