[PATCH] Remove final traces of long-deprecated "ramdisk" kernelparm.

From: Robert P. J. Day
Date: Tue Aug 28 2007 - 02:54:19 EST



Since the "ramdisk" kernel parameter has been officially deprecated
since at least 2.6.18, might as well finally get rid of it.

Signed-off-by: Robert P. J. Day <rpjday@xxxxxxxxxxxxxx>

---

compile tested with "make defconfig" under i386. did i miss any
equally-deletable references?


Documentation/kernel-parameters.txt | 4 ----
Documentation/m68k/kernel-options.txt | 4 ++--
Documentation/ramdisk.txt | 4 ----
drivers/block/rd.c | 7 +------
4 files changed, 3 insertions(+), 16 deletions(-)

diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
index b41cde3..a7ec922 100644
--- a/Documentation/kernel-parameters.txt
+++ b/Documentation/kernel-parameters.txt
@@ -1439,14 +1439,10 @@ and is between 256 and 4096 characters. It is defined in the file
raid= [HW,RAID]
See Documentation/md.txt.

- ramdisk= [RAM] Sizes of RAM disks in kilobytes [deprecated]
- See Documentation/ramdisk.txt.
-
ramdisk_blocksize= [RAM]
See Documentation/ramdisk.txt.

ramdisk_size= [RAM] Sizes of RAM disks in kilobytes
- New name for the ramdisk parameter.
See Documentation/ramdisk.txt.

rcu.blimit= [KNL,BOOT] Set maximum number of finished
diff --git a/Documentation/m68k/kernel-options.txt b/Documentation/m68k/kernel-options.txt
index 59108ce..8a523f6 100644
--- a/Documentation/m68k/kernel-options.txt
+++ b/Documentation/m68k/kernel-options.txt
@@ -192,10 +192,10 @@ Devices possible for Atari:
seconds.


-2.6) ramdisk=
+2.6) ramdisk_size=
-------------

-Syntax: ramdisk=<size>
+Syntax: ramdisk_size=<size>

This option instructs the kernel to set up a ramdisk of the given
size in KBytes. Do not use this option if the ramdisk contents are
diff --git a/Documentation/ramdisk.txt b/Documentation/ramdisk.txt
index 52f75b7..2986bc6 100644
--- a/Documentation/ramdisk.txt
+++ b/Documentation/ramdisk.txt
@@ -29,10 +29,6 @@ in drivers/block/rd.c. To use RAM disk support with your system, run
start with minor number 0 for /dev/ram0, etc. If used, modern kernels use
/dev/ram0 for an initrd.

-The old "ramdisk=<ram_size>" has been changed to "ramdisk_size=<ram_size>" to
-make it clearer. The original "ramdisk=<ram_size>" has been kept around for
-compatibility reasons, but it may be removed in the future.
-
The new RAM disk also has the ability to load compressed RAM disk images,
allowing one to squeeze more programs onto an average installation or
rescue floppy disk.
diff --git a/drivers/block/rd.c b/drivers/block/rd.c
index 65150b5..8833239 100644
--- a/drivers/block/rd.c
+++ b/drivers/block/rd.c
@@ -486,17 +486,12 @@ static int __init ramdisk_size(char *str)
rd_size = simple_strtol(str,NULL,0);
return 1;
}
-static int __init ramdisk_size2(char *str) /* kludge */
-{
- return ramdisk_size(str);
-}
static int __init ramdisk_blocksize(char *str)
{
rd_blocksize = simple_strtol(str,NULL,0);
return 1;
}
-__setup("ramdisk=", ramdisk_size);
-__setup("ramdisk_size=", ramdisk_size2);
+__setup("ramdisk_size=", ramdisk_size);
__setup("ramdisk_blocksize=", ramdisk_blocksize);
#endif

--
========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry
Waterloo, Ontario, CANADA

http://crashcourse.ca
========================================================================
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/