Re: [x86 setup 17/33] A20 handling code

From: H. Peter Anvin
Date: Tue Jul 10 2007 - 14:37:30 EST


Jan Engelhardt wrote:
>> +
>> +#define A20_TEST_ADDR (4*0x80)
>> +#define A20_TEST_SHORT 32
>> +#define A20_TEST_LONG 2097152 /* 2^21 */
>
> Maybe...?
> #define A20_TEST_LONG (1 << 21)

That makes it look like it's a magic value or bitmask, it's not. The
value 2^21 is largely arbitrary, it's just what happened to be in the
previous code.

>> +/* Quick test to see if A20 is already enabled */
>> +static int a20_test_short(void)
>> +{
>> + return a20_test(A20_TEST_SHORT);
>> +}
>> +
>> +/* Longer test that actually waits for A20 to come on line; this
>> + is useful when dealing with the KBC or other slow external circuitry. */
>> +static int a20_test_long(void)
>> +{
>> + return a20_test(A20_TEST_LONG);
>> +}
>
> To me looks like some of these (or other functions) could return bool.

Does it matter? It will generate worse code.

-hpa
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/