Re: [PATCH 1/2] PTRACE_PEEKDATA consolidation
From: Andrew Morton
Date: Tue Jun 12 2007 - 15:53:10 EST
On Tue, 12 Jun 2007 00:52:25 +0400
Alexey Dobriyan <adobriyan@xxxxxxxxx> wrote:
> On Mon, Jun 11, 2007 at 09:35:17PM +0100, Christoph Hellwig wrote:
> > On Tue, Jun 12, 2007 at 12:40:06AM +0400, Alexey Dobriyan wrote:
> > > Identical implementations of PTRACE_PEEKDATA go into
> > > simple_ptrace_peekdata() function.
> > >
> > > compile-tested on ~half of archs, playing with gdb on x86_64.
> > Looks good. Why don't you call it generic_ptrace_peekdata instead of
> > simple_ptrace_peekdata, though?
> Because they're simple :) I was probably spoiled by libfs.c .
Yeah, generic_* would be more typical. I edited the diffs...
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/