Re: [KJ] Re: [PATCH] drivers/isdn/hisax: ARRAY_SIZE instead of sizeof

From: Andi Drebes
Date: Mon Jun 11 2007 - 14:52:10 EST

> I think what was meant here was to remove _all_ the macros that you
> assigned to the ARRAY_SIZE() macro.
Yes, absolutely. I overlooked the 'eg.' in Jan-Benedict's post. Sorry for that.

> If you look at the two advantages replacing code with the ARRAY_SIZE()
> macro has;
> 1. More readable/consistent code.
> 2. Faster compile times, because of less macros being defined.
ack. The arguments for the consistency that I mentioned in my last post
don't hold for a solution that removes all of the macros. So I'm absolutely
fine with a new patch that removes them all.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at