radeonfb problem in

From: DervishD
Date: Sun Jun 10 2007 - 19:25:31 EST

Hi all :))

CONFIG_DRM_RADEON, my system hangs badly as soon as I start X Window
System (namely X.Org 7.2, although it happens in older versions too).

I'm not completely sure about the hanging: the system may not be
hung, but I don't have a console and the keyboard doesn't work, so I
cannot go back to a VT. For me, it's hung.

I've tested different combinations, and if I remove the DRM part,
then XOrg works but it slows to a crawl. If I remove the framebuffer
support, then I can load the DRM part and X works great (only I need the
console with framebuffer, so...).

I've tried "UseFBDev", I've tried setting the same resolution in the
framebuffer and the XOrg, etc. and nothing works. X hangs the system if
I use the framebuffer :(((

The system is a DIY Linux box with vanilla, XOrg 7.2 (self
compiled, tested with Debian XOrg and Ubuntu XOrg too) and a PCIe ATI
Radeon X300 (chipset RV370) running on an AMD64 system.

Is there anything I can do to be able to use both framebuffer
(100x30, which is 800x600) and XOrg without having to wait 15 seconds in
each screen redraw under X?

Thanks a lot in advance :))

Raúl Núñez de Arenas Coronado

Linux Registered User 88736 | http://www.dervishd.net
It's my PC and I'll cry if I want to... RAmen!
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/