Re: [kvm-devel] [BUG] Oops with KVM-27

From: Avi Kivity
Date: Sun Jun 10 2007 - 08:23:08 EST

Luca wrote:
On 6/5/07, Avi Kivity <avi@xxxxxxxxxxxx> wrote:
Luca Tettamanti wrote:
> Il Mon, Jun 04, 2007 at 11:51:10PM +0300, Avi Kivity ha scritto:
>>> While doing repeated tests with the installer I ran into another
>>> (unrelated) problem. Sometimes the guest kernel hangs at boot at:
>>> NET: Registered protocol family 2
>>> with any kind of networking options (except for -net none, which works).
>>> With -no-kvm it boots with any networking option.
>> Can you try to pin the guest on a single core with taskset:
>> taskset 1 qemu ...
> Doesn't help. What works is 'nolapic', i.e. disabling the local APIC on
> the guest kernel.
> I've also tried disabling TSC (notsc) and forcing PIT as the clocksource
> (clocksouce=pit clock=pit); neither of them helped.

Is this a regression relative to a previous kvm version?

sorry for the delay, I was having troubles compiling older KVMs with a
recent kernel...
The last version that works is kvm-21; starting from kvm-22 the VM
hangs during network initialization (now always, but pretty often).
This only occurs when the guest is Fedora7 setup ISO. The regular boot
(i.e. from the hd) seems unaffected.

I've managed to reproduce this on kvm-21 (it takes many boots for this to happen, but it does eventually).

error compiling committee.c: too many arguments to function

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at