Re: [PATCH] FILESYSTEMS: Delete unused "int dummy[5]" from inodes_stat_t.

From: Robert P. J. Day
Date: Wed May 30 2007 - 07:41:28 EST


On Wed, 30 May 2007, Adrian Bunk wrote:

> On Wed, May 30, 2007 at 08:41:56AM +0200, Stefan Richter wrote:
> > From: Stefan Richter <stefanr@xxxxxxxxxxxxxxxxx>
> > Subject: fs: clarify "dummy" member in struct inodes_stat_t
> >
> > Found by Robert P. J. Day: The role of inodes_stat_t.dummy wasn't clear
> > and one might be tempted to remove it. Give it a better name and add a
> > comment.
> >
> > Signed-off-by: Stefan Richter <stefanr@xxxxxxxxxxxxxxxxx>
> > ---
> > Only quickly compile-tested.
> >
> > Index: linux/include/linux/fs.h
> > ===================================================================
> > --- linux.orig/include/linux/fs.h
> > +++ linux/include/linux/fs.h
> > @@ -44,7 +44,7 @@ extern int get_max_files(void);
> > struct inodes_stat_t {
> > int nr_inodes;
> > int nr_unused;
> > - int dummy[5];
> > + int reserved[5]; /* for sysctl and procfs ABI compatibility */
> > };
> > extern struct inodes_stat_t inodes_stat;
>
> Considering that we export this struct to usespace, I don't think
> renaming a member without a good reason is a good idea (but adding a
> comment makes sense).

that makes sense but, given that that array is guaranteed to always
contain zeroes and therefore no useful information, it might be
amusing to rename it just to see what userspace apps break because
they're referring to it by name for what should be no good reason.

no, no, just kidding ... that would be cruel. :-)

rday

p.s. i apologize for this thread having gotten this involved -- i
thought i was submitting a fairly innocuous patch. live and learn.

--
========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry
Waterloo, Ontario, CANADA

http://fsdev.net/wiki/index.php?title=Main_Page
========================================================================
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/