Re: [PATCH 1/4] fs: Introduce path_component_lookup

From: Christoph Hellwig
Date: Sun May 06 2007 - 07:14:36 EST


I wrote up the suggestion before my first morning tea yesterday
and must admit that the name path_component_lookup is pretty stupid.
We don't just look up a component but any relative path starting
from the vfsmount/dentry pair. How about vfs_path_lookup instead
because it mirrors various other vfs_ function that are dentry based?

Also as a new exported symbol it should get a kerneldoc comment describing
it.

> + if (likely(retval == 0)) {
> + if (unlikely(!audit_dummy_context() && nd && nd->dentry &&
> + nd->dentry->d_inode))
> + audit_inode(name, nd->dentry->d_inode);
> + }

This should get the same simplification I suggested for do_path_lookup.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/