Re: [patch]clarification of coding style regarding conditionalstatements with two branches

From: Jan Engelhardt
Date: Fri May 04 2007 - 17:18:00 EST



On May 4 2007 16:48, Jiri Slaby wrote:
>>
>> +Do not unnecessarily use braces where a single statement will do.
>> +
>> +if (condition)
>> + action();
>> +
>> +This does not apply if one branch of a conditional statement is a single
>> +statement. Use braces in both branches.
>
>Why, what's wrong with
>if (condition) {
> do_this();
> do_that();
>} else
> otherwise();
>
>? It's more readable/nicer in my eyes.

I'll just point to an opinion:
http://lkml.org/lkml/2006/9/5/36 , lower half. ("Secondly, whenever...")


Jan
--
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/