Re: [patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

From: Adam Litke
Date: Mon Mar 26 2007 - 10:17:27 EST


On Fri, 2007-03-23 at 15:42 -0700, Ken Chen wrote:
> rename hugetlb_zero_setup() to hugetlb_file_setup() to better match
> function name convention like shmem implementation. Also add an
> argument to the function to indicate whether file setup should reserve
> hugetlb page upfront or not.
>
> Signed-off-by: Ken Chen <kenchen@xxxxxxxxxx>

This patch doesn't really look bad at all, but...

I am worried that what might seem nice and clean right now will slowly
get worse. This implements an interface on top of another interface
(char device on top of a filesystem). What is the next hugetlbfs
function that will need a boolean switch to handle a character device
special case?

Am I just worrying too much here? Although my pagetable_operations
patches aren't the most popular right now, they do have at least one
advantage IMO: they enable side-by-side implementation of the interfaces
as opposed to stacking them. Keeping them separate removes the need for
if ((vm_flags & VM_HUGETLB) && (is_hugetlbfs_chardev())) checking.

--
Adam Litke - (agl at us.ibm.com)
IBM Linux Technology Center

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/