Re: [SOUND] hda_intel: build fix

From: Takashi Iwai
Date: Mon Mar 12 2007 - 10:43:41 EST


At Mon, 12 Mar 2007 13:53:51 +0000,
Ralf Baechle wrote:
>
> On Mon, Mar 12, 2007 at 12:04:30PM +0100, Takashi Iwai wrote:
>
> > It's no big problem to remove const in these cases, but allowing const
> > with __devinitdata seems the right fix to me...
>
> Gccs derives the readability of a section used with __attribute(section())
> from the first use, which in case of this driver was a non-const use, so
> gcc made .init.data a r/w section. Later uses were marked with const,
> so did conflict. Having to ensure that all members of a section are const
> or are not const is painful, so this is clearly less than desirable
> behaviour on gcc's side. I think gcc picking the most permissive
> attributes for a section, that is r/w in this case would be far preferable.
>
> Here is a small test case btw:
>
> int foo __attribute__ ((__section__ (".init.data"))) = 23;
> const int bar __attribute__ ((__section__ (".init.data"))) = 42;
>
> Now I'm not a great fan of the patch I've posted but it reflects what real
> world gcc is doing so for the time being I don't see much of a chance to
> The Right Thing (TM). And the gain from const in this case will be small
> anyway.

Fair enough. I agree that removing const is the only reasonable fix
right now. But from semantics, const is a good thing, and people may
try to add it again later if we get rid of them now. So, how about to
comment out such as /*const*/ in each place to remind that it's
intentional?

Also, in your patch to ice1712, you don't have to remove const from the
codes in snd_ice1712_read_eeprom() and snd_ice1712_probe() functions.
They should work as const pointer.


Takashi
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/