lots of code could be simplified by using ARRAY_SIZE()
From: Robert P. J. Day
Date: Wed Dec 13 2006 - 15:03:28 EST
there are numerous places throughout the source tree that apparently
calculate the size of an array using the construct
"sizeof(fubar)/sizeof(fubar[0])". see for yourself:
$ grep -Er "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" *
but we already have, from "include/linux/kernel.h":
#define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
a simple script to make the appropriate cleanup, given the directory
name as an argument:
================== cut ================
#!/bin/sh
DIR=$1
for f in $(grep -Erl "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" ${DIR}) ;
do
echo "Fixing $f ..."
perl -pi -e "s|sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)|ARRAY_SIZE\(\1\)|" $f
done
=======================================
of course, the file must (eventually) include linux/kernel.h but one
would think that applies to the majority of the source tree, no?
just a thought.
rday
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/