Re: [PATCH 2/3] fsstack: Generic get/set lower object functions

From: Trond Myklebust
Date: Fri Nov 03 2006 - 16:22:51 EST


On Fri, 2006-11-03 at 15:47 -0500, Josef Sipek wrote:
> I was thinking about this a bit, and it would seem that not having get/set
> function pretty much kills the reson to have generic pointer structures at
> all.
>
> Would it make sense to change filesystems like ecryptfs to open-code all
> these things instead of using _their own_ get/set functions (e.g.,
> ecryptfs_inode_to_lower)?
>
> Other posibility is to move the lower pointers into generic VFS objects in
> some clever way (not to waste memory on regular filesystems) - this way, the
> stackable filesystems can still share some parts.

In order for this to be useful, you and the ecryptfs folks need to sit
down and figure out what functionality all these stackable filesystems
want to share.

For instance, there is nothing wrong with moving ecryptfs_d_revalidate()
into a common libstackfs.c if it turns out that several filesystems want
to do the same thing. This is particularly true if you find common
locking needs (as is the case with ecryptfs_do_create(), for instance)
since locks are a good example of something you never want to debug more
than once.

Given all the fun things that can happen with intents in the lower_level
filesystem lookup() code, then that is probably a prime candidate for
some nice helper functions to make everyone's lives easy too...

Cheers,
Trond

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/