Re: dealing with excessive includes

From: Jan Engelhardt
Date: Wed Oct 18 2006 - 12:18:47 EST



>> +#define lock_super(x) do { \
>> + struct super_block *sb = x; \
>> + get_fs_excl(); \
>> + mutex_lock(&sb->s_lock); \
>> +} while(0)
>
>Don't do this. The "x" passed in may be "sb", and then you end up with
>bogus code.

So how about:

static inline void lock_super(struct super_block *sb)
{
get_fs_excl();
mutex_lock(&sb->s_lock);
return;
}

which avoids any naming issue.


-`J'
--
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/