Re: [PATCH 00 of 23][-mm] Unionfs: Stackable Namespace Unification Filesystem

From: Pekka Enberg
Date: Fri Oct 13 2006 - 02:54:31 EST


On 10/12/06, Andrew Morton <akpm@xxxxxxxx> wrote:
Meanwhile, from a quick scan I'd say that unionfs is much, much too lightly
commented for a review to be particularly effective. Please work on that.

Could use some basic coding style fixes too.

- Move assignments outside of if statement expression "if (err = foo_bar())"
- No C99-style comments "//"
- Use struct kmem_cache instead of the deprecated kmem_cache_t
- Don't use function-like macros as the left hand side of assignment
expression "itohi_ptr(inode) = kzalloc(size, GFP_KERNEL);". It's much
better to open-code the assignment or introduce a setter function
(e.g. inode_set_hiptr).
- Kill wrappers (e.g. unionfs_kill_block_super can be replaced with
generic_shutdown_super)

Pekka
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/