Help needed on 2.6.18, Irq and SATA controler.

From: ygosset
Date: Wed Sep 27 2006 - 12:08:46 EST


I boot on an SATA drive,
with this kernel:2.6.12-12mdk .

Here is an lspci on my sata controler:
01:08.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID
Controller (rev 50)
Subsystem: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
Latency: 32
Interrupt: pin A routed to IRQ 16
Region 0: I/O ports at a000 [size=8]
Region 1: I/O ports at a400 [size=4]
Region 2: I/O ports at a800 [size=8]
Region 3: I/O ports at ac00 [size=4]
Region 4: I/O ports at b000 [size=16]
Region 5: I/O ports at b400 [size=256]
Expansion ROM at <unassigned> [disabled] [size=64K]
Capabilities: [c0] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
01:08.0 Class 0104: 1106:3149 (rev 50)

I have tried to compile and install the latest kernel: 2.6.18,
and I can't boot.
I have found a little difference in log between this kernel:
in 2.6.18, I haven't a line "PCI: Via IRQ fixup for 0000:01:08.0, from 11 to
I have this choice for the irq on 2.6.18:
"sata_via(0000:01:08.0): routed to hard irq line 11"
and after these errors:
"ata 1.00 : qc timeout (cmd 0xec)
ata 1: port is slow to respond
Kernel panic

I have this from the first kernel (v2.6.12) in syslog:
"Sep 26 12:15:38 mybox kernel: PCI: Via IRQ fixup for 0000:01:08.0, from 11 to
"Sep 26 12:15:38 mybox kernel: sata_via(0000:01:08.0): routed to hard irq line

So, in the file quirks.c from 2.6.18 kernel,
I have added this line

I have still the same error:
Via IRQ fixup is applied but it is impossible to boot,
even with append=" acpi=off pci=biosirq " in lilo.conf.


Yvan Gosset.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at