Re: 2.6.18 BUG: unable to handle kernel NULL pointer dereferenceat virtual address 000,0000a

From: Nick Piggin
Date: Mon Sep 25 2006 - 09:25:37 EST

Christian Weiske wrote:


I assume that you have confirmed that the machine doesn't have hardware
problems? Does it run some earlier kernel OK?

The disks are both fine, they worked in other pcs without problems. The
ide controller card also worked fine, and the motherboard is new -
whatever you can expect with that. Maybe the combination is the problem.

Memory, motherboard, and CPU would be possible candidates, in roughly
that order of likelihood. If you can run memtest86+ on it overnight,
that would provide a bit more confidence in all.

Can you try using a different IDE controller to reproduce the panic
on the same system?

And how long does it take to crash?

After starting the yacy daemon, it's about half a minute until the
"possible recursive locking detected" appears, and after one or two
minutes the whole thing crashes.

I wonder if that does anything unusual apart from use the network?
Can you break it with anything else? a big ftp transfer?


Send instant messages to your online friends -
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at