Re: [PATCH 0/11] LTTng-core (basic tracing infrastructure) 0.5.108

From: Ingo Molnar
Date: Fri Sep 15 2006 - 08:47:44 EST



* Martin J. Bligh <mbligh@xxxxxxxxxx> wrote:

> >i.e. we should have macros to prepare local information, with macro
> >arities of 2, 3, 4 and 5:
> >
> > _(name, data1);
> > __(name, data1, data2);
> > ___(name, data1, data2, data3);
> > ____(name, data1, data2, data3, data4);
>
> Personally I think that's way more visually offensive that something
> that looks like a function call, but still ;-) We do it as a caps
> macro
>
> KTRACE(foo, bar)
>
> internally, which I suppose makes it not look like a function call.
> But at the end of the day, it's all just a matter of visual taste,
> what's actually in there is way more important.

i disagree with the naming, for the reasons stated before: if we add any
static info to the kernel, it's a "easier data extraction" thing (for
the purposes of speeding up dynamic tracing), not a tracepoint. That way
there's no dispute whether what i remove is a tracepoint (on which
static tracers might rely in a hard way), or just a speedup for
SystemTap. So a better name would be what SystemTap has implemented
today:

STAP_MARK_NN(kernel_context_switch, prev, next);

or what makes this even more explicit:

DEBUG_DATA(kernel_context_switch, prev, next);

(but i'm flexible about the naming - as long as it doesnt say 'trace'
and as long as there are no guarantees at all that those points remain,
when a better method of accessing the same data for dynamic tracers is
implemented.)

Ingo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/