Re: [Patch] Off by one in drivers/usb/input/yealink.c

From: Henk Vergonet
Date: Wed Jul 05 2006 - 09:13:42 EST



Sorry for the late response guys, but I was on holliday.

No no no, please dont use this.


On Tue, Jun 27, 2006 at 03:51:43PM -0700, Randy.Dunlap wrote:
> On Wed, 28 Jun 2006 00:41:19 +0200 Eric Sesterhenn wrote:
> > another off by one spotted by coverity (id #485),
> > we loop exactly one time too often
> >
> > Signed-off-by: Eric Sesterhenn <snakebyte@xxxxxx>
> >
> > --- linux-2.6.17-git11/drivers/usb/input/yealink.c.orig 2006-06-28 00:29:46.000000000 +0200
> > +++ linux-2.6.17-git11/drivers/usb/input/yealink.c 2006-06-28 00:30:04.000000000 +0200
> > @@ -350,7 +350,7 @@ static int yealink_do_idle_tasks(struct
> > val = yld->master.b[ix];
> > if (val != yld->copy.b[ix])
> > goto send_update;
> > - } while (++ix < sizeof(yld->master));
> > + } while (++ix < sizeof(yld->master)-1);

Apart from introducing a new bug in the code, the construct is ugly.

I would rather see then the more readable:

ix++;
} while (ix < sizeof(yld->master));

- Henk
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/