Re: [Patch] statistics infrastructure - update 9

From: Andrew Morton
Date: Tue Jul 04 2006 - 03:18:10 EST


On Tue, 4 Jul 2006 08:17:54 +0200
Heiko Carstens <heiko.carstens@xxxxxxxxxx> wrote:

> > +
> > +static inline void statistic_add_as(int type, struct statistic *stat, int i,
> > + s64 value, u64 incr)
> > +{
> > +}
> > +
> > +#endif /* CONFIG_STATISTICS */
>
> Why not have something like:
>
> #define statistic_create(interface, name) ({ 0; })
> #define statistic_remove(interface) ({ 0; })
> #define statistic_set(stat, i, value, total) do { } while (0)
> ...
>
> That would be much shorter and easier to read. But maybe it's just me :)

typechecking.

struct scsi_device s;
int foo;

statistic_create(s, foo_with_a_typo); /* whee */

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/