Re: [patch 07/61] lock validator: better lock debugging

From: Ingo Molnar
Date: Fri Jun 23 2006 - 06:28:53 EST



* Andrew Morton <akpm@xxxxxxxx> wrote:

> > +#define DEBUG_WARN_ON(c) \
> > +({ \
> > + int __ret = 0; \
> > + \
> > + if (unlikely(c)) { \
> > + if (debug_locks_off()) \
> > + WARN_ON(1); \
> > + __ret = 1; \
> > + } \
> > + __ret; \
> > +})
>
> Either the name of this thing is too generic, or we _make_ it generic,
> in which case it's in the wrong header file.

this op is only intended to be used only by the lock debugging
infrastructure. So it should be renamed - but i fail to find a good name
for it. (it's used quite frequently within the lock debugging code, at
60+ places) Maybe INTERNAL_WARN_ON()? [that makes it sound special
enough.] DEBUG_LOCKS_WARN_ON() might work too.

> > +#ifdef CONFIG_SMP
> > +# define SMP_DEBUG_WARN_ON(c) DEBUG_WARN_ON(c)
> > +#else
> > +# define SMP_DEBUG_WARN_ON(c) do { } while (0)
> > +#endif
>
> Probably ditto.

agreed.

Ingo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/