Re: [patch 36/61] lock validator: special locking: serial

From: Ingo Molnar
Date: Fri Jun 23 2006 - 05:53:20 EST



* Andrew Morton <akpm@xxxxxxxx> wrote:

> > +/*
> > + * lockdep: port->lock is initialized in two places, but we
> > + * want only one lock-type:
> > + */
> > +static struct lockdep_type_key port_lock_key;
> > +
> > /**
> > * uart_set_options - setup the serial console parameters
> > * @port: pointer to the serial ports uart_port structure
> > @@ -1869,7 +1875,7 @@ uart_set_options(struct uart_port *port,
> > * Ensure that the serial console lock is initialised
> > * early.
> > */
> > - spin_lock_init(&port->lock);
> > + spin_lock_init_key(&port->lock, &port_lock_key);
> >
> > memset(&termios, 0, sizeof(struct termios));
> >
> > @@ -2255,7 +2261,7 @@ int uart_add_one_port(struct uart_driver
> > * initialised.
> > */
> > if (!(uart_console(port) && (port->cons->flags & CON_ENABLED)))
> > - spin_lock_init(&port->lock);
> > + spin_lock_init_key(&port->lock, &port_lock_key);
> >
> > uart_configure_port(drv, state, port);
> >
>
> Is there a cleaner way of doing this?
>
> Perhaps write a new helper function which initialises the spinlock,
> call that? Rather than open-coding lockdep stuff?

yes, we can do that too - but that would have an effect to non-lockdep
kernels too.

Also, the initialization of the 'port' seems a bit twisted here, already
initialized and not-yet-initialized ports can be passed in to
uard_add_one_port(). So i did not want to touch the structure of the
code - hence the open-coded solution.

Ingo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/