Re: [RFC/PATCH 1/2] slab: cpucache allocation cleanup

From: Christoph Lameter
Date: Sat Jun 17 2006 - 12:37:18 EST


On Thu, 15 Jun 2006, Pekka Enberg wrote:

> -static inline void *____cache_alloc(struct kmem_cache *cachep, gfp_t flags)
> +static __always_inline void *__cache_alloc_cpucache(struct kmem_cache *cachep,

The new name is confusing because __cache_alloc_cpucache suggests that we
are only allocating from the cpucache and that this be something special.
However, we always allocate from the cpucache for local allocations and we
refill the cpucache in the __cpucache function from the shared cache and
the per node lists. So we do much more there.

Maybe call this __cache_alloc_local ?

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/