Re: [stable] [PATCH] sbp2: fix check of return value of hpsb_allocate_and_register_addrspace

From: Stefan Richter
Date: Sat Jun 03 2006 - 06:43:52 EST


Andrew Morton wrote:
On Sat, 03 Jun 2006 11:31:27 +0200
Andreas Schwab <schwab@xxxxxxx> wrote:
Michael Tokarev <mjt@xxxxxxxxxx> writes:
* Stefan Richter (stefanr@xxxxxxxxxxxxxxxxx) wrote:
- if (!scsi_id->status_fifo_addr) {
+ if (scsi_id->status_fifo_addr == ~0ULL) {

Umm. Can this ~0ULL constant be #define'd to something?
It's way too simple to mis-read it as NULL (or ~NULL whatever).

How about writing it as -1?

That's preferable.

It doesn't actually cause a problem, but status_fifo_addr is defined as
u64, which is not `unsigned long long'. On powerpc, for example, u64 is
implemented as unsigned long. -1 just works.

I have a patch ready which replaces the magic value by a sensibly named preprocessor constant. Will be posted within the hour. Thanks for the comments.
--
Stefan Richter
-=====-=-==- -==- ---==
http://arcgraph.de/sr/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/