Re: functions named similar (pci_acpi_init)

From: Muthu Kumar
Date: Fri Apr 28 2006 - 03:42:07 EST


[PATCH] ACPI PCI: Rename the functions to avoid multiple instances.

There were two instances of pci_acpi_init(), one in
drivers/pci/pci-acpi.c and another in arch/i386/pci/acpi.c.
Rename the one in pci-acpi.c and make it consistent with
other names in the same file.

Signed-off-by: Muthukumar R <muthur@xxxxxxxxx>

diff --git a/drivers/pci/pci-acpi.c b/drivers/pci/pci-acpi.c
index 6917c6c..d84e25c 100644
--- a/drivers/pci/pci-acpi.c
+++ b/drivers/pci/pci-acpi.c
@@ -257,7 +257,7 @@ static int acpi_pci_set_power_state(stru


/* ACPI bus type */
-static int pci_acpi_find_device(struct device *dev, acpi_handle *handle)
+static int acpi_pci_find_device(struct device *dev, acpi_handle *handle)
{
struct pci_dev * pci_dev;
acpi_integer addr;
@@ -271,7 +271,7 @@ static int pci_acpi_find_device(struct d
return 0;
}

-static int pci_acpi_find_root_bridge(struct device *dev, acpi_handle *handle)
+static int acpi_pci_find_root_bridge(struct device *dev, acpi_handle *handle)
{
int num;
unsigned int seg, bus;
@@ -289,21 +289,21 @@ static int pci_acpi_find_root_bridge(str
return 0;
}

-static struct acpi_bus_type pci_acpi_bus = {
+static struct acpi_bus_type acpi_pci_bus = {
.bus = &pci_bus_type,
- .find_device = pci_acpi_find_device,
- .find_bridge = pci_acpi_find_root_bridge,
+ .find_device = acpi_pci_find_device,
+ .find_bridge = acpi_pci_find_root_bridge,
};

-static int __init pci_acpi_init(void)
+static int __init acpi_pci_init(void)
{
int ret;

- ret = register_acpi_bus_type(&pci_acpi_bus);
+ ret = register_acpi_bus_type(&acpi_pci_bus);
if (ret)
return 0;
platform_pci_choose_state = acpi_pci_choose_state;
platform_pci_set_power_state = acpi_pci_set_power_state;
return 0;
}
-arch_initcall(pci_acpi_init);
+arch_initcall(acpi_pci_init);
















On 4/27/06, Greg KH <greg@xxxxxxxxx> wrote:
> On Thu, Apr 27, 2006 at 05:27:49PM -0700, Muthu Kumar wrote:
> > thanks.. How about the following to make the names consistent with others in
> > that file:
>
> Looks good to me. Can you resend it with a proper changelog comments
> and a Signed-off-by: so I can apply it?
>
> thanks,
>
> greg k-h
>
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/