[patch 0/8] list.h related cleanups

From: Akinobu Mita
Date: Thu Mar 30 2006 - 03:16:43 EST


This patch set does:

- Introduce hlist_add_head() and use it
- Use list_add_tail() instead of list_add(A, B.prev)
- Use list_move() instead of the combination of list_del() and list_add()

for readability and micro optimization.
--
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/