Re: [PATCH] for_each_possible_cpu [1/19] defines for_each_possible_cpu

From: Nick Piggin
Date: Wed Mar 15 2006 - 22:41:06 EST


KAMEZAWA Hiroyuki wrote:
Now,
for_each_cpu() is for-loop cpu over cpu_possible_map.
for_each_online_cpu is for-loop cpu over cpu_online_map.
.....for_each_cpu() looks bad name.

This patch renames for_each_cpu() as for_each_possible_cpu().

I also wrote patches to replace all for_each_cpu with for_each_possible_cpu.
please confirm....

BTW, when HOTPLUC_CPU is not suppoted, using for_each_possible_cpu()
should be avoided, I think.

all patches are against 2.6.16-rc6-mm1.


for_each_cpu() effectively is for_each_possible_cpu() as far as
generic code is concerned. In other words, nobody would ever expect
for_each_cpu to return an _impossible_ CPU, thus you are just
adding a redundant element to the name.

The only places where things might care is arch bootup code, but
the cpu interface is such that the arch code is expected to _hide_
any weird details from these generic interfaces.

--
SUSE Labs, Novell Inc.
Send instant messages to your online friends http://au.messenger.yahoo.com -
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/