Re: [PATCH] Document Linux's memory barriers [try #4]

From: Linus Torvalds
Date: Thu Mar 09 2006 - 18:54:30 EST




On Fri, 10 Mar 2006, Michael Buesch wrote:
>
> So what about:
>
> #define spin_lock_mmio(lock) spin_lock(lock)
> #define spin_unlock_mmio(lock) do { spin_unlock(lock); mmiowb(); } while (0)

You need to put the mmiowb() inside the spinlock.

Yes, that is painful. But the point being that if it's outside, then when
somebody else gets the lock, the previous lock-owners MMIO stores may
still be in flight, which is what you didn't want in the first place.

Anyway, no need to make a new name for it, since you might as well just
use the mmiowb() explicitly. At least until this has been shown to be a
really common pattern (it clearly isn't, right now ;)

Linus
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/