Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation

From: Nikita Danilov
Date: Thu Dec 15 2005 - 13:21:41 EST


Linus Torvalds writes:
>
>
> On Thu, 15 Dec 2005, David Howells wrote:
> >
> > FROM TO
> > ============================== =========================
> > DECLARE_MUTEX DECLARE_SEM_MUTEX
> > DECLARE_MUTEX_LOCKED DECLARE_SEM_MUTEX_LOCKED
> > Proper counting semaphore DECLARE_SEM
>
> That sounds fine. I wouldn't be adverse to doing that - but it would have
> to be independently of any other changes, and it would need to simmer for
> a while for out-of-tree drivers etc to notice (ie you should _not_ just
> introduce a new "DECLARE_MUTEX()" immediately to confuse things).

Going off at a tangent (or tangle, rather), why do we need DECLARE_FOO()
macros at all? They

- do not look like C variable declarations, hide variable type, and
hence are confusing,

- contrary to their naming actually _define_ rather than _declare_ an
object.

In most cases

type var = INIT_FOO;

is much better (more readable and easier to understand) than

DECLARE_FOO(var); /* what is the type of var? */

In the cases where initializer needs an address of object being
initialized

type var = INIT_FOO(var);

can be used.

Nikita.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/