Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation

From: Mark Lord
Date: Wed Dec 14 2005 - 18:56:50 EST


Thomas Gleixner wrote:
On Wed, 2005-12-14 at 18:40 -0500, Mark Lord wrote:
...
Leaving up()/down() as-is is really the most sensible option.

...
Doing a s/down/lock_mutex/ s/up/unlock_mutex/ - or whatever naming
convention we want to use - all over the place for mutexes while keeping
the up/down for counting semaphores is an one time issue.

After the conversion every code breaks at compile time which tries to do
up/down(mutex_type).

So the out of tree drivers have a clear indication what to fix. This is
also a one time issue.

So where is the problem - except for fixing "huge" amounts of out of
kernel code once ?

Pointless API breakage. The same functions continue to exist,
the old names CANNOT be reused for some (longish) time,
so there's no point in renaming them. It just breaks an API
for no good reason whatsoever.

Cheers
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/