Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation

From: Matthew Wilcox
Date: Tue Dec 13 2005 - 07:39:10 EST


On Tue, Dec 13, 2005 at 10:48:19AM +0000, David Howells wrote:
> > > +#define is_mutex_locked(mutex) ((mutex)->state)
> >
> > Let's keep the namespace consistent. mutex_is_locked().
>
> But that's a poor name: it turns it from a question into a statement:-(

Ah, but look at it in context of how it's used:

if (is_mutex_locked())
That's gramatically incorrect!

if (mutex_is_locked())
much better.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/