Re: [patch 00/21] hrtimer - High-resolution timer subsystem

From: Ingo Molnar
Date: Wed Dec 07 2005 - 05:48:16 EST



* Nick Piggin <nickpiggin@xxxxxxxxxxxx> wrote:

> Ingo Molnar wrote:
>
> >so i believe that:
> >
> > - 'struct ktimer', 'struct ktimeout'
> >
> >is in theory superior naming, compared to:
> >
> > - 'struct ptimer', 'struct timer_list'
> >
>
> Just curious -- why the "k" thing?

yeah. 'struct timer' and 'struct timeout' is even better. I tried it on
real code and sometimes it looked a bit funny: often we have a 'timeout'
parameter somewhere that is a scalar or a timeval/timespec. So at least
for variable names it was useful to have it in this form:

struct timeout *ktimeout;

struct timer *ktimer;

otherwise it looked OK. This is also in line with most other 'object
names' we have in the kernel: struct inode, struct dentry.

Ingo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/