Re: [PATCH 1/7]: PCI revised (2) [PATCH 16/42]: PCI: PCI Error reporting callbacks

From: Greg KH
Date: Mon Nov 07 2005 - 16:37:56 EST


On Mon, Nov 07, 2005 at 03:21:28PM -0600, linas wrote:
> +typedef int __bitwise pci_channel_state_t;

Closer but...

> enum pci_channel_state {
> - pci_channel_io_normal = 0, /* I/O channel is in normal state */
> - pci_channel_io_frozen = 1, /* I/O to channel is blocked */
> - pci_channel_io_perm_failure, /* PCI card is dead */
> + pci_channel_io_normal = (__force pci_channel_state_t) 0, /* I/O channel is in normal state */
> + pci_channel_io_frozen = (__force pci_channel_state_t) 1, /* I/O to channel is blocked */
> + pci_channel_io_perm_failure = (__force pci_channel_state_t) 2, /* PCI card is dead */
> };

You don't have to use an enum anymore, just use a #define.

Sparse developers, I see code in the kernel that that does both
(__force foo_t) and (foo_t __force). Which one is correct?


> +typedef int __bitwise pers_result_t;

Ugh, I don't like that name, but I can't think of anything better right
now. You should at least keep "pci" at the beginning to make it make
more sense to people looking at it for the first time.

thanks,

greg k-h
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/