Re: init and zap low address mappings on demand for cpu hotplug

From: Andrew Morton
Date: Wed Sep 21 2005 - 16:13:22 EST


Ashok Raj <ashok.raj@xxxxxxxxx> wrote:
>
> +/*
> + * mode
> + * 0 indicates its for __cpu_up to kick an AP into boot sequence.
> + * 1 indicates completion os smp boot process, so we can zap the low
> + * until there is need to bring a cpu up again.
> + */
> +__cpuinit void zap_low_mappings(int mode)

grump. `mode' is a terrible identifier name. Better to call it something
which identifies its meaning if true, such as `do_mapping_zapping' or
something.

Even better, implement two nicely-named functions rather than passing in a
`mode' argument. Those functions can of course share a common
mode-selected implementation internally.


And that comment is incomprehensible, partly due to all its typos. Care to
try again?

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/