Re: [PATCH] use kzalloc instead of malloc+memset

From: Paul Jackson
Date: Tue Sep 13 2005 - 18:29:40 EST


Andrew wrote:
> It hurts readability. Quick question: is this code correct?
>
> dev = kmalloc(sizeof(struct net_device), GFP_KERNEL);

And it hurts maintainability. If someone changes 'dev' so
that it is no longer of type 'struct net_device', then they
risk missing this allocation, and introducing what could be
a nasty memory corruption kernel bug.

--
I won't rest till it's the best ...
Programmer, Linux Scalability
Paul Jackson <pj@xxxxxxx> 1.925.600.0401
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/