Re: [PATCH 1/7] shared subtree

From: Miklos Szeredi
Date: Sun Jul 31 2005 - 03:27:34 EST

> > Do you still believe that your idea is simpler?
> Well, you have bundled do_make_slave(), pnode_member_to_slave() and
> empty_pnode() all into one function. I think your original split is
> quite nice. If you'd split this function up like that, I think you'd
> agree, that the end result is simpler.

Also you can still use the pnode concept in naming functions and
explanations. For example empty_pnode() is a good function name even
if there's no 'struct pnode'. Pnodes still exist, they just don't
have a corresponding object.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at