Re: "seeing minute plus hangs during boot" - 2.6.12 and 2.6.13

From: Francisco Figueiredo Jr.
Date: Sun Jul 31 2005 - 00:39:11 EST

Hash: SHA1

Andrew Morton wrote:
> "Francisco Figueiredo Jr." <fxjrlists@xxxxxxxxxxxx> wrote:
>>udev S 00000002 0 1312 1 1224 (NOTLB)
>> c1653f4c 00000082 c1653f3c 00000002 00000001 00000040 c1653f64 c1653f0c
>> c016611b bfec96a8 c1653f0c 00000040 00000000 00000361 000241ed
>> c13fb520
>> 00000001 00001a7e 98f9769f 00000002 c146e520 df5da020 df5da148
>> c13fbf60
>> Call Trace:
>> [<c016611b>] cp_new_stat+0x15f/0x17a
>> [<c0352a74>] schedule_timeout+0x54/0xa2
>> [<c01274ce>] process_timeout+0x0/0x9
>> [<c01275c4>] sys_nanosleep+0xdd/0x18e
>> [<c0102e85>] syscall_call+0x7/0xb
> Well there's your delay: you've started running userspace and udev is
> running. Yes, it takes a long time.
> What makes you think this isn't normal behaviour? Do other kernels behave
> differently with the same userspace setup?

That's the point. On kernel 2.6.11 on same box I have no delay. It is
instantaneous. On 2.6.12-rc1 it was instantaneous but I didn't use it
much because I had drm problems. Later I tried 2.6.12 final and it was
hanging. I saw the "seeing a minute plugs hangs" on 2.6.13-rc1 release
notes and thought this could be the problem, but I compiled it and tried
with no luck :(

Now, I'm thinking it could be something like the udev hang which
disapeared with udev update to 058.

I don't know what can be happening. I think it is because of some type
of timeout.

If you think there is something else I can do, please let me know.

Thanks in advance for your help, Andrew.

- --

Francisco Figueiredo Jr.
Npgsql Lead Developer
MonoBrasil Project Founder Member

- -------------
"Science without religion is lame;
religion without science is blind."

~ Albert Einstein
Version: GnuPG v1.2.6 (GNU/Linux)
Comment: Using GnuPG with Thunderbird -


Yahoo! Acesso Grátis - Internet rápida e grátis.
Instale o discador agora!
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at