Re: 2.6.13-rc3-mm3

From: Andrew Morton
Date: Fri Jul 29 2005 - 14:41:31 EST

Michael Thonke <tk-shockwave@xxxxxx> wrote:
> Andrew Morton schrieb:
> > Michael Thonke <iogl64nx@xxxxxxxxx> wrote:
> >> here again I have two problems. With 2.6.13-rc3-mm3 I have problems
> >> using my SATA drives on Intel ICH6.
> >> The kernel can't route there IRQs or can't discover them. the option
> >> irqpoll got them to work now.
> >> The problem is new because 2.6.13-rc3[-mm1,mm2] work without any problems.
> >
> > OK. Please generate the full dmesg output for -mm2 and for -mm3 and run
> > `diff -u dmesg.mm2 dmesg.mm3' and send it? And keep those files because we
> > may end up needing to add them to an acpi bugzilla entry ;)
> Well I did a little only worked correctly up to
> 2.6.13-rc3-mm1 but this dmesg output I have.
> Well as I save mm[2,3] are unable to setup the correct IRQs for the
> devices..and please note that 2.6.13-rc3-mm3 only booted with irqpoll so
> its in the dmesg output "dmesg.mm3"
> Normaly the IRQ routed to something about 1xx now they are 1-21?! Caused
> by irqpoll?

Are these problems only present in -mm kernels? Does 2.6.13-rc4 work OK?

> > Odd trace. Do you have CONFIG_KALLSYMS enabled? If not, please turn it on.
> Mh I tried but my system freezes on boot then. And screen leaves blank.
> >

Oh geeze.

@@ -53,10 +23,18 @@
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
+ ACPI-0287: *** Error: Region SystemMemory(0) has no handler
+ ACPI-0127: *** Error: acpi_load_tables: Could not load namespace: AE_NOT_EXIST
+ ACPI-0136: *** Error: acpi_load_tables: Could not load tables: AE_NOT_EXIST
+ACPI: Unable to load the System Description Tables
-..TIMER: vector=0x31 pin1=2 pin2=0
+..TIMER: vector=0x31 pin1=2 pin2=-1
NET: Registered protocol family 16
PCI: Using configuration type 1
+ACPI: Subsystem revision 20050708
+ACPI: Interpreter disabled.

Well it looks like ACPI committed suicide, so there's probably not much
point looking at the other things until that gets addressed.

Would you have time to raise a kernel bugzilla entry for this? Raise it
against the ACPI AML interpreter, version 20050708 and mention the above
failure. The output of acpidump (from
will probably be asked for.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at