US Robotics (Hardware) Modem Not Detected

From: Brad Davis
Date: Wed Jul 27 2005 - 08:47:20 EST

I'm trying to get a PCI-USRobotics Modem (Yes, it is a true hardware
modem) working on a G4 with Kernel version 2.6.10/2.6.11.

When I try to "modprobe 8250_pci". I get the following
error message:

WARNING: Error inserting 8250
(/lib/modules/2.6.10enrock.2/kernel/drivers/serial/8250.ko): No such
FATAL: Error inserting 8250_pci
Unknown symbol in module, or unknown parameter (see dmesg)

It looks to me like the 8250 module isn't recognizing the modem as a
seial port. The appropriate lines from dmesg are:

serial8250_init: nothing to do on PowerMac
8250_pci: Unknown symbol serial8250_unregister_port
8250_pci: Unknown symbol serial8250_resume_port
8250_pci: Unknown symbol serial8250_register_port
8250_pci: Unknown symbol serial8250_suspend_port

The "serial_core" module is correctly loaded as it shows up with a
lsmod. I get the same results whether I enable the PCI card (via
"setpci -d 12b9:1008 command=1") before the modprobe or not.

Everything looks good with lspci -vv (below). The card has an
allocated IO address (0x1020) and IRQ (53). It is disabled (I/O-), but
I understand the serial driver will enable it when it is found. There
are no /dev/ttyS* devices, but I also understand that these will be
created by the driver/udev system when the module has been correctly
loaded. I have tried manually creating a /dev/ttyS* file and then
tried to use setserial on it, but it complains.

I am currently dual-booting this machine with 2.4.X kernel and the
modem works fine there, so I guess something has changed in the new
2.6.X modules.

Output from lspci -vv:
0001:11:03.0 Serial controller: 5610 56K FaxModem 56K FaxModem Model
5610 (rev 01) (prog-if 02 [16550])
Subsystem: 5610 56K FaxModem USR 56k Internal Voice Modem (Model 2976)
Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
Interrupt: pin A routed to IRQ 53
Region 0: I/O ports at 1020 [disabled] [size=8]
Capabilities: [dc] Power Management version 2
Flags: PMEClk- DSI- D1- D2+ AuxCurrent=0mA
Status: D0 PME-Enable- DSel=0 DScale=2 PME-

Can someone point me in the right direction to get this card working
with the 2.6 kernel stream?

Thanks in advance for any help.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at