Re: IRQ routing problem in 2.6.10-rc2

From: Jesper Juhl
Date: Sun Jul 24 2005 - 09:17:22 EST

On 7/24/05, Pierre Ossman <drzeus-list@xxxxxxxxx> wrote:
> Sorry about reporting this error so late but the machine in question had
> gone some time without upgrades.
> The problem I'm seeing is that IRQs stop working for one of the IRQ
> slots on the machine. It's only that slot, not the entire IRQ, since the
> two slots (it's a small machine) both get routed to IRQ 10.
> I've included dmesg from 2.6.10-rc1 (which works) and 2.6.10-rc2 (which
> doesn't).
> I've also tried reverting the patches that modifies
> arch/i386/kernel/irq.c and arch/i386/pci/irq.c but it didn't solve the
> problem. So now I need some more input on which patches to try.
> Linux version 2.6.10-rc2 (root@xxxxxxxxxxxxxxxxx) (gcc version 3.3.3 20040412 (Red Hat Linux 3.3.3-7)) #8 Wed Jul 20 02:57:15 CEST 2005
> ACPI: Using PIC for interrupt routing
> PCI: Using ACPI for IRQ routing
> ** PCI interrupts are no longer routed automatically. If this
> ** causes a device to stop working, it is probably because the
> ** driver failed to call pci_enable_device(). As a temporary
> ** workaround, the "pci=routeirq" argument restores the old
> ** behavior. If this argument makes the device work again,
> ** please email the output of "lspci" to bjorn.helgaas@xxxxxx
> ** so I can fix the driver.
Have you tried the suggestion given "... As a temporary workaround,
the "pci=routeirq" argument..." ?
You could also try the pci=noacpi boot option to see if that changes anything.

Also, that's a fairly old kernel you have there, could you try
2.6.13-rc3, 2.6.13-rc3-git6 or 2.6.13-rc3-mm1 ?

Jesper Juhl <jesper.juhl@xxxxxxxxx>
Don't top-post
Plain text mails only, please
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at