2.6.12 kernel panic after loading promise_sata module

From: Robert Gadsdon
Date: Mon Jun 20 2005 - 04:39:50 EST

Tried 2.6.12 (vanilla) kernel, and had the following at boot:
(typed from screen)
Starting balanced_irq
Freeing unused kernel memory: 220k freed
Red Hat nash version 4.1.18 starting
Mounted /proc filesystem
Mounting sysfs
input: AT Translated set 2 keyboard on isa0060/serio0
Creating /dev
Starting udev
Loading libata.ko module
Loading sata_promise.ko module
Creating root device
Mounting root filesystem
mount: error 6 mounting ext3
mount: error 2 mounting none
Switching to new root
switchroot: mount failed: 22
umount /initrd/dev failed: 2
kernel panic - not syncing: Attempted to kill init!


Reverted to and everything worked OK.

UDEV version is 058

SATA controller card (from lspci):
00:12.0 Unknown mass storage controller: Promise Technology, Inc. PDC20318 (SATA150 TX4) (rev 02)

gcc version is 3.4.4

Robert Gadsdon
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/