Re: [PATCH] PCI Hotplug: more CPCI updates

From: Prarit Bhargava
Date: Wed Jun 01 2005 - 21:46:53 EST


Prarit Bhargava wrote:
Greg KH wrote:

[PATCH] PCI Hotplug: more CPCI updates


- Switch to pci_get_slot instead of deprecated pci_find_slot.
- A bunch of CodingStyle fixes.


- }
+ dev = pci_get_slot(slot->bus, PCI_DEVFN(slot->number, 0));
+ if (dev) {
+ if (update_adapter_status(slot->hotplug_slot, 1))
+ warn("failure to update adapter file");
+ if (update_latch_status(slot->hotplug_slot, 1))
+ warn("failure to update latch file");
+ slot->dev = dev;
}
}


I don't claim to know the code as well as Scott or Greg does, but I don't see a pci_put_dev for the slot->dev to clean up the usage count?


s/pci_put_dev/pci_dev_put/g

:)

P.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/