Re: Linux Alpha port: LVM

From: Rao Davide
Date: Thu Apr 28 2005 - 08:53:46 EST

Sorry to bother you all ... the problem was that I issued some options during configuration to specify where the kernel was, apparently I should only do that on 2.4 series kernels.

I re-extracted the kernel sources and started over again. It's nor working fine now.

Thanks anyway
Davide Rao
Client/server Unix
Atos Origin
Via C.Viola - Pont St. Martin (AO) Italy
Cell : +39 3357599151
Tel : +39 125810433
Email: davide.rao@xxxxxxxxxxxxxx

Davide Rao wrote:
Is LVM working on the alpha port 2.6 kernel series ?

works fine for me.

Are you using a redhat based distro (like suse, mandrake, alpha core or indeed redhat )?
Are you using stock kernel, libraries and tools or did you haveto build them yourself ?
Debian comes with LVM1 tools that do not work with 2.6 kernels so I need to compile them myself or install some ready build binary package for alpha processor and compatible with the libraries that come with debian3.
What alpha architecture are you running on ?

If so where do I get libdevmapper so that I can build the userspace LVM utils ?

I tryied downloading

what do you think the 'dm' in that url stands for, hm?

But I fail to compile it so I'm also unable tu build the userspace lvm utils.

'userspace lvm utils' can be found here:

multipath tools might be something different ... :)

It may also have something more but it has libdevmapper in it ...
In any case I also tried downloading and compiling device-mapper.1.00.07.tgz from the link in the LVM2.
It builds and installe fine but I still get compilation errore when I build LVM2.
Configute is fine, here are a few lines concerning libdevmapper

checking libdevmapper.h usability... yes
checking libdevmapper.h presence... yes
checking for libdevmapper.h... yes

but when I try to compile:

gcc -c -I. -I../include -DLVM1_INTERNAL -DPOOL_INTERNAL -DCLUSTER_LOCKING_INTERNAL -DSNAPSHOT_INTERNAL -DMIRRORED_INTERNAL -DDEVMAPPER_SUPPORT -DO_DIRECT_SUPPORT -DHAVE_LIBDL -DHAVE_GETOPTLONG -fPIC -Wall -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -O2 cache/lvmcache.c -o cache/lvmcache.o
activate/activate.c: In function `target_present':
activate/activate.c:303: error: `DM_DEVICE_LIST_VERSIONS' undeclared (first use in this function)
activate/activate.c:303: error: (Each undeclared identifier is reported only once
activate/activate.c:303: error: for each function it appears in.)
activate/activate.c:314: warning: implicit declaration of function `dm_task_get_versions'
activate/activate.c:314: warning: nested extern declaration of `dm_task_get_versions'
activate/activate.c:314: warning: assignment makes pointer from integer without a cast
activate/activate.c:319: error: dereferencing pointer to incomplete type
same message repeated many times
make[1]: *** [activate/activate.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/usr/src/LVM2.2.01.09/lib'
make: *** [lib] Error 2

I'm using kernel downloaded from
Here's the relevent section for raid/lvm in config:
# Multi-device support (RAID and LVM)
# CONFIG_MD_RAID10 is not set
# CONFIG_MD_RAID6 is not set
# CONFIG_DM_CRYPT is not set
# CONFIG_DM_MIRROR is not set
# CONFIG_DM_ZERO is not set

Do I need to patch kernel ?

Davide Rao
Client/server Unix
Atos Origin
Via C.Viola - Pont St. Martin (AO) Italy
Cell : +39 3357599151
Tel : +39 125810433
Email: davide.rao@xxxxxxxxxxxxxx

73 Thorsten

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at