Re: [PATCH][RFC][0/4] InfiniBand userspace verbs implementation

From: Timur Tabi
Date: Tue Apr 26 2005 - 09:10:15 EST

Andrew Morton wrote:

Precisely. That's why I suggested that we have an alternative vma->vm_flag
bit which behaves in a similar manner to VM_LOCKED (say, VM_LOCKED_KERNEL),
only userspace cannot alter it.

How about calling it VM_PINNED? That way, we can define

Locked - won't be swapped to disk, but can be moved around in memory
Pinned - won't be swapped to disk or moved around in memory

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at