Re: X86_64: 2.6.12-rc3 spontaneous reboot

From: Parag Warudkar
Date: Sun Apr 24 2005 - 17:00:35 EST

I haven't tried to reproduce it since it will cause me data loss :(
I am not sure it is possible to go to this extent in order to reproduce
the reboot but still... Here is what I was doing when the error occured -
I installed Ubuntu AMD64 5.04 release. Installed 2.6.12-rc3.
Installed and configured a chroot env for 32bit programs. (dchroot)
Installed 32bit JRE from Sun - latest one. Tried to install
Borland Together J Eclipse edition under the chrooted environment
- Just before the install finished, machine rebooted. Machine was
running for couple hours before the reboot.


> On Sunday 24 April 2005 04:41, Alexander Nyberg wrote:
> > sön 2005-04-24 klockan 00:08 -0400 skrev Parag Warudkar:
> > > While running a 32 bit Java program 2.6.12-rc3 rebooted spontaneously
> leaving
> > > a corrupt partition table and disk with errors. There was nothing in dmesg
> > > (no oops/panic) except some -MARK- entries during the reboot.
> > >
> >
> > Is this reproducible? If so, can you give a detailed description of how.
> I think rc3 has code from rc2-mm2/3. Both of these reboot here randomly.
> Nothing
> shows up on a serial console... Think something is seriously wrong with x86_64
> in rc3.
> That being said its possible its fixed in HEAD by.
> [PATCH] x86_64: fix new out of line put_user()
> [PATCH] x86_64: Bug in new out of line put_user()
> some people have reported reversing (in -mm)
> sched-unlocked-context-switches.patch
> Helps too.
> Ed Tomlinson
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at