Re: [PATCH 3/4] readahead: factor out duplicated code

From: Oleg Nesterov
Date: Thu Feb 03 2005 - 05:42:55 EST


Ram wrote:
> > unsigned long page_cache_readahead(mapping, ra, filp, offset, req_size)
> > {
> > unsigned long max, newsize = req_size;
> > int sequential = (offset == ra->prev_page + 1);
> >
> > if (offset == ra->prev_page && req_size == 1 && ra->size != 0)
> > goto out;
> > ra->prev_page = offset; <============== PLEASE LOOK HERE :)
> > max = get_max_readahead(ra);
> > newsize = min(req_size, max);
> >
> > if (newsize == 0 || (ra->flags & RA_FLAG_INCACHE)) {
> > newsize = 1;
>
> At this point prev_page has to be updated:
> ra->prev_page = offset;

Yes, it is already updated, before "max = get_max_readahead(ra);"

> Otherwise this code looks much cleaner and correct. Can you send me a
> updated patch. I will run it through my test harness.

Well, currently I do not know, what should be changed :)

Oleg.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/