Re: [PATCH] Rename SECTOR_SIZE to BIO_SECTOR_SIZE

From: Matt Mackall
Date: Wed Oct 27 2004 - 15:40:59 EST


On Wed, Oct 27, 2004 at 12:05:23PM -0700, Chris Wedgwood wrote:
> Rename (one of the uses of) SECTOR_SIZE to BIO_SECTOR_SIZE which is
> more appropriate.

> Index: cw-current/include/linux/ide.h
> ===================================================================
> --- cw-current.orig/include/linux/ide.h 2004-10-27 11:33:06.237319044 -0700
> +++ cw-current/include/linux/ide.h 2004-10-27 11:35:13.246711414 -0700
> @@ -202,8 +202,8 @@
> #define PARTN_BITS 6 /* number of minor dev bits for partitions */
> #define PARTN_MASK ((1<<PARTN_BITS)-1) /* a useful bit mask */
> #define MAX_DRIVES 2 /* per interface; 2 assumed by lots of code */
> -#define SECTOR_SIZE 512
> -#define SECTOR_WORDS (SECTOR_SIZE / 4) /* number of 32bit words per sector */
> +#define BIO_SECTOR_SIZE 512
> +#define SECTOR_WORDS (BIO_SECTOR_SIZE / 4) /* number of 32bit words per sector */
> #define IDE_LARGE_SEEK(b1,b2,t) (((b1) > (b2) + (t)) || ((b2) > (b1) + (t)))

So shouldn't this be in bio.h now?

--
Mathematics is the supreme nostalgia of our time.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/