Re: [RFC] Rename SECTOR_SIZE to MSDOS_SECTOR_SIZE

From: OGAWA Hirofumi
Date: Wed Oct 27 2004 - 08:13:37 EST


cw@xxxxxxxx (Chris Wedgwood) writes:

> -#define SECTOR_SIZE 512 /* sector size (bytes) */
> -#define SECTOR_BITS 9 /* log2(SECTOR_SIZE) */
> +#define MSDOS_SECTOR_SIZE 512 /* sector size (bytes) */
> +#define MSDOS_SECTOR_BITS 9 /* log2(SECTOR_SIZE) */
> #define MSDOS_DPB (MSDOS_DPS) /* dir entries per block */
> #define MSDOS_DPB_BITS 4 /* log2(MSDOS_DPB) */
> -#define MSDOS_DPS (SECTOR_SIZE / sizeof(struct msdos_dir_entry))
> +#define MSDOS_DPS (MSDOS_SECTOR_SIZE / sizeof(struct msdos_dir_entry))
> #define MSDOS_DPS_BITS 4 /* log2(MSDOS_DPS) */

The fatfs doesn't use these (is separated by two blank lines).
These are for just backward compatibility.

To rename is not useful at all, please delete instead if it's needed.
--
OGAWA Hirofumi <hirofumi@xxxxxxxxxxxxxxxxxx>
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/